Support

Zuletzt bearbeitet am: 20.04.2023

Frequently asked questions

klarnaAuthorizationToken must not be empty

Error message

The message klarnaAuthorizationToken must not be empty appears if parts of the Klarna plugin such as Twig blocks or JavaScript elements are missing during checkout.

Cause

Among other things the Twig block page_checkout_confirm in the file src/Resources/views/storefront/page/checkout/confirm/index.html.twig is extended.

Solution

Please empty the cache and recompile the files for the storefront via bin/build-storefront.js. Make sure that no other plugin overwrites the necessary extensions of the Klarna plugin by deactivating other plugins one by one and checking the behaviour again.

addressChangeDeclined or lineItemChangeDeclined

Error description

When updating an order, the error message 'KlarnaPayment.errorMessages.lineItemChangeDeclined' or 'KlarnaPayment.errorMessages.addressChangeDeclined' appears.

Cause

  • Due to Klarna's risk assessment, changes to order items and address are no longer possible once an amount has been captured via Klarna.
  • To synchronise relevant changes to the order with Klarna, the Klarna plugin stores a hash of the address (klarna_order_address_hash) and the order items (klarna_order_cart_hash) in the custom fields of the order respectively. When the order is updated, the hashes are regenerated and compared with the existing ones. This is a simple way for the Klarna plugin to determine whether relevant data has been changed and to transfer this to Klarna. This can also result in an error message if the comparison is not possible due to missing hashes and no relevant data has been changed.

Solution

If you have not made any changes to the address or order items, please check the custom fields of the order via the database. If the mentioned hashes from the Klarna plugin are missing there, please contact plugin support.

B2b sale

Error description

When trying to complete an order, a pop-up appears with the message.

An error has occurred. We are currently experiencing technical difficulties with this payment method. Please choose another payment method

Cause

A company is stored in the billing address used.

Solution

Selling to other companies is only possible with Klarna in certain countries. For this, see the answer to the question Can I sell to other companies with Klarna? from Klarna merchant support.


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